Skip to main content
htaccess

PHP 5 via .htaccess unterdrückt

Das sind die Momente da möchte ich am liebsten die Flugfähigkeit meines Notebooks testen. So eine verd…. Frickelei.

Worum geht es?

Ich habe in meinem Testsystem ein das Plugin DiggDigg, welches die schönen Vote Button rechts neben diesen text bringt, installiert. Das Plugin läuft fehlerfrei und alles ist schön! Auch alle anderen Plugins laufen perfekt. Also ab damit ins Livesystem http://PIXELtunes.de. Und – eVoilà. Das Plugin erzeugt einen schweren fehler und kann nicht aktiviert werden 🙁
Parse error: syntax error, unexpected T_CLASS in /www/htdocs/v160577/weblog/wp-content/plugins/digg-digg/dd.class.php on line 5

Der Autor des Plugins teilte mir via Kommentar in seinem Blog mit das es an der falschen PHP version liegen würde? Hmm, eigentlich Blödsinn dachte ich. All-Inkl hat alle meine Accounts inzwischen auf PHP 5 umgestellt. Kann nicht sein – muß was anderes sein. Also mal schön stundenlang alte versionen des Plugins untersucht, verglichen und testweise installiert. Nix, gleicher Fehler immer noch.

Ok, was sagt mir denn eigentlich die infophp.php? Im Testsystem läuft PHP 5 🙂 und im Livesystem … richtig – PHP 4 🙁

Also schnell mal schauen wie denn die anderen Projekte aufgestellt sind? In jedem anderen bei All-Inkl gehosteten Projekt läuft auch PHP 5. *fcuk* Nur nicht in meinem Blog!!!

Ich habe dann um 22.40 Uhr per Mail den Support von All-Inkl gebeten auch in meinem Projekt Ordner die version PHP 5 einzustellen! Die Antwort ließ genau 11 Minuten auf sich warten und kam damit schneller als das Schreiben dieses Artikels dauern wird. In meiner .htaccess wurde händisch die Version PHP 4 aufgerufen.
´AddHandler php4-cgi .php´

Fix diese Zeile gelöscht und zack lief das Plugin. Tolle Wurst 🙁

Und wenn diese Zeilen für jemanden hilfreich sind, freue ich mich sehr über einen Kommentar oder einen Klick auf die bunten Buttons 😉

Ähnliche Artikel

Ein Gedanke zu „PHP 5 via .htaccess unterdrückt

  1. Hi,

    ich stand heute tatsächlich vor dem gleichen Problem, nur dass bei meinem Hoster sowohl PHP4 als auch PHP5 bereits aktiviert waren… nachdem ich dann meinen Server auf „PHP5 exklusiv“ umgestellt hatte, funktionierte auch das Plugin!

    Also, vielen Dank für die Beitrag!

    Grüße
    JayMGee

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.